import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d+\\s*[\\s+|\\-+]\\s*\\d+\\s*\\/\\s*\\d+(?!\\d*\\s*\\-))";
final String string = " RIH W/17 1/2\" NEW M.T BIT, 9 1/2\" SH.SUB & 9 1/2\" MONEL, TAG BTM @ 45'\n"
+ "N/U 13 5/8\"-5K X 11\"-10 K PSI CIW C.H.SPOOL\n"
+ " OFF BTN / ON BTM TQ: 5 - 6 / 10 -16 KLB.FT.";
final String subst = ", ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}