#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "t(a|o|u)"
Local $sString = "tatotu"
Local $sSubst = "T$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)