const regex = /t(a|o|u)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('t(a|o|u)', 'g')
const str = `tatotu`;
const subst = `T$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);