package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+%(?:\s+INT)?`)
var str = `100%, 1%, 90% INT, 9%, 5% INT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}