$re = '/\d+%(?:\s+INT)?/m';
$str = '100%, 1%, 90% INT, 9%, 5% INT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);