const regex = /^([\w-.]+@(?!gmail\.com)(?!yahoo\.com)(?!hotmail\.com)(?!mail\.com)(?!live\.com)(?!aol\.com)(?!outlook\.com)(?!msn\.com)(?!ymail\.com)([\w-]+.)+[\w-]{2,4})?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w-.]+@(?!gmail\\.com)(?!yahoo\\.com)(?!hotmail\\.com)(?!mail\\.com)(?!live\\.com)(?!aol\\.com)(?!outlook\\.com)(?!msn\\.com)(?!ymail\\.com)([\\w-]+.)+[\\w-]{2,4})?$', '')
const str = `maykel@marfin.co`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}