$re = '/^([\w-.]+@(?!gmail\.com)(?!yahoo\.com)(?!hotmail\.com)(?!mail\.com)(?!live\.com)(?!aol\.com)(?!outlook\.com)(?!msn\.com)(?!ymail\.com)([\w-]+.)+[\w-]{2,4})?$/';
$str = 'maykel@marfin.co';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);