package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([ATGC{2,6}]{2,6})`)
var str = `ACACACGTACAC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}