$re = '/([ATGC{2,6}]{2,6})/m';
$str = 'ACACACGTACAC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);