using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"foo=(?<foo>\d+) bar=(?<bar>\d+) apple=(?<apple>"".*?"") msg=(?<msg>"".*?"") host=(?<host>"".*?"")";
string input = @"foo=2 bar=3 apple=""hello"" msg=""hello world"" host=""stackoverflow.com""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}