import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "foo=(?<foo>\\d+) bar=(?<bar>\\d+) apple=(?<apple>\".*?\") msg=(?<msg>\".*?\") host=(?<host>\".*?\")";
final String string = "foo=2 bar=3 apple=\"hello\" msg=\"hello world\" host=\"stackoverflow.com\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}