package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\d+)|(\d+\d+)$`)
var str = `07 51 30 38 92`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}