$re = '/^(\d+\d+)|(\d+\d+)$/m';
$str = '07 51 30 38 92';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);