import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?<!stay )short";
final String string = "Our system's recommendation today is to STAY SHORT. The previous SHORT signal was issued on 30.08.2018, 1 day ago, when the stock price was 43.9250. Market attention is now on the downside. SHORT is a dangerous signal. Sudden increases in prices can lead to huge losses. For this reason stop loss levels must be kept in mind at all times and SHORT orders must never be placed without a stop loss";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}