use strict;
my $str = 'Our system\'s recommendation today is to STAY SHORT. The previous SHORT signal was issued on 30.08.2018, 1 day ago, when the stock price was 43.9250. Market attention is now on the downside. SHORT is a dangerous signal. Sudden increases in prices can lead to huge losses. For this reason stop loss levels must be kept in mind at all times and SHORT orders must never be placed without a stop loss';
my $regex = qr/(?i)(?<!stay )short/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}