re = /(?i)(EDIResources\/EDITradingPartnerUpdates\/tabid((?:(?!\?).)*))(.*)/i
str = 'www.1edisource.com/ediresources/editradingpartnerupdates/tabid=123
www.1edisource.com/ediresources/editradingpartnerupdates/tabid=123?gclid=jjj
www.1edisource.com/ediresources/editradingpartnerupdates/tabid
www.1edisource.com/ediresources/editradingpartnerupdates/tabid?gclid=jjj'
subst = 'category/trading-parter-update$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result