$re = '/(?:[^a-z\n]*[a-z]){2}/m';
$str = 'WoW a
Food';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);