$re = '/([\p{L}\w]+)/';
$str = 'testé
kragén
und
gürtel
émail
élder
messé
émit
èmit
testè
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);