re = /([\p{L}\w]+)/
str = 'testé
kragén
und
gürtel
émail
élder
messé
émit
èmit
testè
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end