package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z\x{0600}-\x{06FF}\x{1000}-\x{1021}_-][-\w]*`)
var str = `Abyssinian 987
Burmese a1a
Dragon Li 2B
987 Cat
cat 987 Toyger
cat A1A Siamese
1
abc-Burmese-a1a`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}