using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d*(?:\.\d+)?)";
string substitution = @"$1";
string input = @"0.2
2.2
2.0
.2
2.2.
0.2.
2.2.2.2.2
0.2.2.2
.22.2.2.2
2222.22
2.
222.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}