import re
regex = re.compile(r"^(\d*(?:\.\d+)?)", flags=re.MULTILINE)
test_str = ("0.2\n"
"2.2\n"
"2.0\n"
".2\n"
"2.2.\n"
"0.2.\n"
"2.2.2.2.2\n"
"0.2.2.2\n"
".22.2.2.2\n"
"2222.22\n"
"2.\n"
"222.")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)