using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"My cow ([\s\S]*)milk";
string input = @"My cow always gives
milk";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}