package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)My cow ([\s\S]*)milk`)
var str = `My cow always gives
milk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}