$re = '/^(?=.*\bjapan\b)(?=.*\buniver(?:sal)?\b)/m';
$str = 'japan universal studios
japan univer';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);