re = /^(?=.*\bjapan\b)(?=.*\buniver(?:sal)?\b)/m
str = 'japan universal studios
japan univer'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end