const regex = /^(?:[A-Za-z]{2}|\d{2})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[A-Za-z]{2}|\\d{2})$', 'gm')
const str = `45
AB
az
Az
A5
a7
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}