$re = '/^(?:[A-Za-z]{2}|\d{2})$/m';
$str = '45
AB
az
Az
A5
a7
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);