#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((([12]{1}\d\d)|(1-9]\d)|([1-9]))[\.]){3}(([12]{1}\d\d)|([1-9]\d)|([1-9]))"
Local $sString = "1.2.3.4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")