re = /((([12]{1}\d\d)|(1-9]\d)|([1-9]))[\.]){3}(([12]{1}\d\d)|([1-9]\d)|([1-9]))/
str = '1.2.3.4'
# Print the match result
str.match(re) do |match|
puts match.to_s
end