$re = '/(?:(?:(between )([\'"]?)(.*?)(\2)( and )([\'"]?)(.*?)(\6)))/i';
$str = 'id between 3 and 10 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);