re = /(?:(?:(between )(['"]?)(.*?)(\2)( and )(['"]?)(.*?)(\6)))/i
str = 'id between 3 and 10 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end