#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:hdd\s+\dtb hdd \dtb(?!\s+hdd)|(?<!hdd\s)\dtb hdd \dtb\s+hdd)(*SKIP)(*F)|\dtb hdd \dtb"
Local $sString = "{sometext...} 1tb hdd 1tb hdd {sometext...}" & @CRLF & _
"{sometext...} 1tb hdd 1tb {sometext...}" & @CRLF & _
"{sometext...} hdd 1tb hdd 1tb {sometext...}" & @CRLF & _
"{sometext...} hdd 1tb hdd 1tb hdd {sometext...}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")