import re
regex = re.compile(r"(?:hdd\s+\dtb hdd \dtb(?!\s+hdd)|(?<!hdd\s)\dtb hdd \dtb\s+hdd)(*SKIP)(*F)|\dtb hdd \dtb", flags=re.MULTILINE)
test_str = ("{sometext...} 1tb hdd 1tb hdd {sometext...}\n"
"{sometext...} 1tb hdd 1tb {sometext...}\n"
"{sometext...} hdd 1tb hdd 1tb {sometext...}\n"
"{sometext...} hdd 1tb hdd 1tb hdd {sometext...}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")