import re
regex = re.compile(r"^label (\S+)(?!.*(?:\n(?!label).*)*?\n[ \t]*\[end_timeline\])", flags=re.MULTILINE)
test_str = ("label Colorcode (Object)\n"
"Dialog\n"
"Speaker: \"Text\"\n"
"Speaker 2: \"[i]Text[/i]! [pause={pause.medium}] more text.\"\n"
"do function_name(\"parameter\", {parameter})\n"
"# comment, there are no inline-comments\n"
"[end_timeline]\n\n"
"label Maroon (Guitar)\n"
"Speaker: \"Text\"\n"
"[end_timeline]\n\n"
"label Pink (Chest)\n"
"Speaker: \"Text\"\n\n"
"label Königsblau (Wardrobe)\n"
"Speaker: \"Text\"\n"
"Speaker: \"Text\"\n"
"Speaker: \"Text\"\n"
"[end_timeline]\n\n"
"label Azur (Sorcerers Hat)\n"
"Speaker: \"Text\"\n"
"# [end_timeline]\n\n"
"label Jade (Paintings)\n"
"Speaker: \"Text\"\n"
"label Gras (Ship in a Bottle)\n"
"Speaker: \"Text\"\n"
"Speaker: \"Text\"\n"
"[end_timeline]\n\n"
"label Goldgelb (Golden Apple)\n"
"Speaker: \"Text\"\n"
"[end_timeline]\n\n"
"label Himmelblau (Helmet)\n"
"Speaker: \"Text\"\n"
"Speaker: \"Text\"\n"
"Speaker: \"Text\"\n"
"Speaker: \"Text\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")