re = /^label (\S+)(?!.*(?:\n(?!label).*)*?\n[ \t]*\[end_timeline\])/m
str = 'label Colorcode (Object)
Dialog
Speaker: "Text"
Speaker 2: "[i]Text[/i]! [pause={pause.medium}] more text."
do function_name("parameter", {parameter})
# comment, there are no inline-comments
[end_timeline]
label Maroon (Guitar)
Speaker: "Text"
[end_timeline]
label Pink (Chest)
Speaker: "Text"
label Königsblau (Wardrobe)
Speaker: "Text"
Speaker: "Text"
Speaker: "Text"
[end_timeline]
label Azur (Sorcerers Hat)
Speaker: "Text"
# [end_timeline]
label Jade (Paintings)
Speaker: "Text"
label Gras (Ship in a Bottle)
Speaker: "Text"
Speaker: "Text"
[end_timeline]
label Goldgelb (Golden Apple)
Speaker: "Text"
[end_timeline]
label Himmelblau (Helmet)
Speaker: "Text"
Speaker: "Text"
Speaker: "Text"
Speaker: "Text"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end