package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.{2})`)
var str = `AAAAAA`
var substitution = "$1bbb"
fmt.Println(re.ReplaceAllString(str, substitution))
}