#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^((?:[0-9A-Fa-f]{2}(?:[:-]?)){7}(?:[0-9A-Fa-f]{2}))$"
Local $sString = "00:13:a2:00:41:8b:93:7a" & @CRLF & _
"0013a200418b937a" & @CRLF & _
"AD:12:13:FC:14:EE:FF:FF" & @CRLF & _
"ad-12-13-fc-14-ee-ff-ad"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)