using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^""\s=]+)=('{[\s\S]*?\n}'|.*)";
string substitution = @"PREFIX_\1: \2";
string input = @"# IN TOTAL, THE REGEX SHOULD MATCH 4 KEY-VALUE PAIRS FROM THIS FILE.
KEY1='{
""string"" = {
""key"" = ""value"",
""key"" = ""value""
},
""string"" = {
""key"" = ""value"",
""key"" = ""value""
}
}'
# DO NOT MATCH ON COMMENTS, EVEN THOSE WITH X=Y in them.
# ALSO IGNORE THIS COMMENT, AND NEW LINES AROUND.
KEY2=SOME_TEXT
KEY3=""SOME_MORE_TEXT""
KEY4='EVEN_MORE_TEXT'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}