// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^([^"\s=]+)=('{[\s\S]*?\n}'|.*)"#).unwrap();
let string = "# IN TOTAL, THE REGEX SHOULD MATCH 4 KEY-VALUE PAIRS FROM THIS FILE.
KEY1='{
\"string\" = {
\"key\" = \"value\",
\"key\" = \"value\"
},
\"string\" = {
\"key\" = \"value\",
\"key\" = \"value\"
}
}'
# DO NOT MATCH ON COMMENTS, EVEN THOSE WITH X=Y in them.
# ALSO IGNORE THIS COMMENT, AND NEW LINES AROUND.
KEY2=SOME_TEXT
KEY3=\"SOME_MORE_TEXT\"
KEY4='EVEN_MORE_TEXT'";
let substitution = "PREFIX_\\1: \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}