# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\h*\R\s*"
test_str = ("<div class=\"input select\">\n"
" <label for=\"countries\">User Country</label>\n"
" <select name=\"countries\" id=\"countries\">\n"
" <option value=\"\">Select a country</option>\n"
" <option value=\"ger\">Germany</option>\n"
" <option value=\"fra\">France</option>\n"
" <option value=\"rus\" selected=\"selected\">Russia</option>\n"
" </select>\n"
" </div>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.