using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\d{1,2}\b)(?=[\d,]+\b\1\b)";
string input = @"1,22,33,34,9,5,11,1,22,33,34,9,5,10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}