$re = '/(\b\d{1,2}\b)(?=[\d,]+\b\1\b)/';
$str = '1,22,33,34,9,5,11,1,22,33,34,9,5,10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);