package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\*\.)?([\w\d]+\.)+[\w\d]+$`)
var str = `correct:
*.test.com
test.com
abc.test.com
Incorrect:
*test.com
test.com*
test.*.com
test.abc*.com
`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}