$re = '/^(\*\.)?([\w\d]+\.)+[\w\d]+$/m';
$str = 'correct:
*.test.com
test.com
abc.test.com
Incorrect:
*test.com
test.com*
test.*.com
test.abc*.com
';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;