$re = '/(.*)\s+([0-9]+(\-[0-9]+)?\s+)?((w|q)[0-9]+(\s+)?)(\..*)$/im';
$str = 'test test 1970-2020 w15.txt
test 1970-2020 w15.csv
test 1990-99 q1.txt
test 1981 w15 .csv
test test w15.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);