import re
regex = re.compile(r"(.*)\s+([0-9]+(\-[0-9]+)?\s+)?((w|q)[0-9]+(\s+)?)(\..*)$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("test test 1970-2020 w15.txt\n"
"test 1970-2020 w15.csv\n"
"test 1990-99 q1.txt\n"
"test 1981 w15 .csv\n"
"test test w15.csv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")