import re
regex = re.compile(r"^https?:\/\/(?:[^\/]+\.)?website\.com(.*\/(?:p)+\/)")
test_str = ("https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582\n\n"
"https://www.innovasport.com/c/p/\n\n"
"https://www.innovasport.com/c/prendas/\n\n"
"https://www.innovasport.com/p/\n\n"
"https://www.innovasport.com/hombres/entrenamiento/textil/puma/playera-puma-fade-printed/p/000000000000198582")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")