#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{1,}[ ][A-Z][a-z]{2}[ ](?:\d{4}[ ]\d{2}[:]\d{2}|\d{2}[:]\d{2})[\s\S]*?(?:(?!\n\n)[\s\S])*?(?=\n\d{1,}[ ])|\d{1,}[ ][A-Z][a-z]{2}[ ](?:\d{4}[ ]\d{2}[:]\d{2}|\d{2}[:]\d{2}).*"
Local $sString = "..." & @CRLF & _
"..." & @CRLF & _
"15 Apr 2014 22:05 - id: content" & @CRLF & _
"15 Apr 2014 22:09 - id: content" & @CRLF & _
"15 Apr 2014 22:09 - id: content" & @CRLF & _
"with new line" & @CRLF & _
"16 Apr 2014 06:56 - id: content" & @CRLF & _
"with new line" & @CRLF & _
"with new line" & @CRLF & _
"16 Apr 2014 06:57 - id: content" & @CRLF & _
"" & @CRLF & _
"16 Apr 2014 06:58 - id: content" & @CRLF & _
"..." & @CRLF & _
"..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")