const regex = /\d{1,}[ ][A-Z][a-z]{2}[ ](?:\d{4}[ ]\d{2}[:]\d{2}|\d{2}[:]\d{2})[\s\S]*?(?:(?!\n\n)[\s\S])*?(?=\n\d{1,}[ ])|\d{1,}[ ][A-Z][a-z]{2}[ ](?:\d{4}[ ]\d{2}[:]\d{2}|\d{2}[:]\d{2}).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{1,}[ ][A-Z][a-z]{2}[ ](?:\\d{4}[ ]\\d{2}[:]\\d{2}|\\d{2}[:]\\d{2})[\\s\\S]*?(?:(?!\\n\\n)[\\s\\S])*?(?=\\n\\d{1,}[ ])|\\d{1,}[ ][A-Z][a-z]{2}[ ](?:\\d{4}[ ]\\d{2}[:]\\d{2}|\\d{2}[:]\\d{2}).*', 'gm')
const str = `...
...
15 Apr 2014 22:05 - id: content
15 Apr 2014 22:09 - id: content
15 Apr 2014 22:09 - id: content
with new line
16 Apr 2014 06:56 - id: content
with new line
with new line
16 Apr 2014 06:57 - id: content
16 Apr 2014 06:58 - id: content
...
...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}